Telnet Options
Registration Procedure(s)
- IETF Review
Reference
- RFC 855: Telnet Option Specifications
Note
The Telnet Protocol has a number of options that may be negotiated. These options are listed here. "Internet Official Protocol Standards" (STD 1) provides more detailed information.
Available Formats
| Options | Name | Reference |
|---|---|---|
| 0 | Binary Transmission | RFC 856 |
| 1 | Echo | RFC 857 |
| 2 | Reconnection | NIC 15391 of 1973 |
| 3 | Suppress Go Ahead | RFC 858 |
| 4 | Approx Message Size Negotiation | NIC 15393 of 1973 |
| 5 | Status | RFC 859 |
| 6 | Timing Mark | RFC 860 |
| 7 | Remote Controlled Trans and Echo | RFC 726 |
| 8 | Output Line Width | NIC 20196 of August 1978 |
| 9 | Output Page Size | NIC 20197 of August 1978 |
| 10 | Output Carriage-Return Disposition | RFC 652 |
| 11 | Output Horizontal Tab Stops | RFC 653 |
| 12 | Output Horizontal Tab Disposition | RFC 654 |
| 13 | Output Formfeed Disposition | RFC 655 |
| 14 | Output Vertical Tabstops | RFC 656 |
| 15 | Output Vertical Tab Disposition | RFC 657 |
| 16 | Output Linefeed Disposition | RFC 658 |
| 17 | Extended ASCII | RFC 698 |
| 18 | Logout | RFC 727 |
| 19 | Byte Macro | RFC 735 |
| 20 | Data Entry Terminal | RFC 1043; RFC 732 |
| 21 | SUPDUP | RFC 736; RFC 734 |
| 22 | SUPDUP Output | RFC 749 |
| 23 | Send Location | RFC 779 |
| 24 | Terminal Type | RFC 1091 |
| 25 | End of Record | RFC 885 |
| 26 | TACACS User Identification | RFC 927 |
| 27 | Output Marking | RFC 933 |
| 28 | Terminal Location Number | RFC 946 |
| 29 | Telnet 3270 Regime | RFC 1041 |
| 30 | X.3 PAD | RFC 1053 |
| 31 | Negotiate About Window Size | RFC 1073 |
| 32 | Terminal Speed | RFC 1079 |
| 33 | Remote Flow Control | RFC 1372 |
| 34 | Linemode | RFC 1184 |
| 35 | X Display Location | RFC 1096 |
| 36 | Environment Option | RFC 1408 |
| 37 | Authentication Option | RFC 2941 |
| 38 | Encryption Option | RFC 2946 |
| 39 | New Environment Option | RFC 1572 |
| 40 | TN3270E | RFC 2355 |
| 41 | XAUTH | Rob Earhart |
| 42 | CHARSET | RFC 2066 |
| 43 | Telnet Remote Serial Port (RSP) | Robert Barnes |
| 44 | Com Port Control Option | RFC 2217 |
| 45 | Telnet Suppress Local Echo | Wirt Atmar |
| 46 | Telnet Start TLS | Michael Boe |
| 47 | KERMIT | RFC 2840 |
| 48 | SEND-URL | David Croft |
| 49 | FORWARD_X | Jeffrey Altman |
| 50-137 | Unassigned | Internet Assigned Numbers Authority |
| 138 | TELOPT PRAGMA LOGON | Steve McGregory |
| 139 | TELOPT SSPI LOGON | Steve McGregory |
| 140 | TELOPT PRAGMA HEARTBEAT | Steve McGregory |
| 141-254 | Unassigned | |
| 255 | Extended-Options-List | RFC 861 |
Telnet Authentication Types (Option 37)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2941: Telnet Authentication Option
Command
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2941: Telnet Authentication Option
Available Formats
Types
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2941: Telnet Authentication Option
Available Formats
| Type | Description | Reference |
|---|---|---|
| 0 | NULL | RFC 2941 |
| 1 | KERBEROS_V4 | RFC 2941 |
| 2 | KERBEROS_V5 | RFC 2942 |
| 3 | SPX | RFC 2941[1] |
| 4 | MINK | RFC 2941[1] |
| 5 | SRP | RFC 2944 |
| 6 | RSA (also used by SRA) | RFC 2941 |
| 7 | SSL | RFC 2941 |
| 8-9 | Unassigned | Internet Assigned Numbers Authority |
| 10 | LOKI | RFC 2941[1] |
| 11 | SSA | Steven Schoch |
| 12 | KEA_SJ | RFC 2951 |
| 13 | KEA_SJ_INTEG | RFC 2951 |
| 14 | DSS | RFC 2943 |
| 15 | NTLM | Louis Kahn[1] |
KERBEROS_V4 Telnet Authentication Type (Type 1)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 1411: Telnet Authentication: Kerberos Version 4
Available Formats
| Suboption | Command | Reference |
|---|---|---|
| 0 | AUTH | RFC 1411 |
| 1 | REJECT | RFC 1411 |
| 2 | ACCEPT | RFC 1411 |
| 3 | CHALLENGE | RFC 1411 |
| 4 | RESPONSE | RFC 1411 |
| 5 | FORWARD | Derrick Brashear |
| 6 | FORWARD-ACCEPT | Derrick Brashear |
| 7 | FORWARD-REJECT | Derrick Brashear |
| 8 | EXP | Thomas Wu |
| 9 | PARAMS | Thomas Wu |
KERBEROS_V5 Telnet Authentication Type (Type 2)
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 2942: Telnet Authentication: Kerberos Version 5
Available Formats
SRP Telnet Authentication Type (Type 5)
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 2944: Telnet Authentication: SRP
Available Formats
KEA_SJ (Type 12) and KEA_SJ_INTEG (Type 13) Authentication Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 2951: TELNET Authentication Using KEA and SKIPJACK
Available Formats
DSS Authentication Type (Type 14)
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 2943: TELNET Authentication Using DSA
Available Formats
Telnet Encryption Types (Option 38)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2946: Telnet Data Encryption Option
Note
In the Telnet Encryption commands and types RFC 2946 there have been various implementations in several widely distributed versions of Telnet (e.g., at MIT, Stanford, and Columbia). Originally, only two encryption types were specified. Additional encryption types have been defined and are listed below. Additions to the list are registered by the IANA and documented here.
Command
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2946: Telnet Data Encryption Option
Available Formats
Types
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2946: Telnet Data Encryption Option
Available Formats
| Type | Description | Reference |
|---|---|---|
| 0 | NULL | RFC 2946 |
| 1 | DES_CFB64 | RFC 2946 |
| 2 | DES_OFB64 | RFC 2946 |
| 3 | DES3_CFB64 | RFC 2946 |
| 4 | DES3_OFB64 | RFC 2946 |
| 5-7 | Unassigned | Internet Assigned Numbers Authority |
| 8 | CAST5_40_CFB64 | RFC 2946 |
| 9 | CAST5_40_OFB64 | RFC 2946 |
| 10 | CAST128_CFB64 | RFC 2946 |
| 11 | CAST128_OFB64 | RFC 2946 |
| 12 | AES_CCM | S. Josefsson |
DES_CFB64 Telnet Encryption Type (Type 1)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2952: Telnet Encryption: DES 64 bit Cipher Feedback
Available Formats
DES_OFB64 Telnet Encryption Type (Type 2)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2953: Telnet Encryption: DES 64 bit Output Feedback
Available Formats
DES3_CFB64 Telnet Encryption Type (Type 3)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2947: Telnet Encryption: DES3 64 bit Cipher Feedback
Available Formats
DES3_OFB64 Telnet Encryption Type (Type 4)
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2948: Telnet Encryption: DES3 64 bit Output Feedback
Available Formats
CAST5_40_CFB64 (Type 8) and CAST128_CFB64 (Type 10) Telnet Encryption Types
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2950: Telnet Encryption: CAST-128 64 bit Cipher Feedback
Available Formats
CAST5_40_OFB64 (Type 9) and CAST128_OFB64 (Type 11) Telnet Encryption Types
Registration Procedure(s)
- First Come First Served
Reference
- RFC 2949: Telnet Encryption: CAST-128 64 bit Output Feedback
Available Formats
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| David Croft | david&infotrek.co.uk | 1998-09 |
| Derrick Brashear | shadow&dementia.org | 1995-01 |
| Internet Assigned Numbers Authority | iana&iana.org | 2012-08 |
| Jeffrey Altman | jaltman&watsun.cc.columbia.edu | 2000-01 |
| Louis Kahn | louiskµsoft.com | 1998-10 |
| Michael Boe | mboe&cisco.com | 1998-06 |
| Rob Earhart | earhart+&cmu.edu | 1995-04 |
| Robert Barnes | rab&stallion.oz.au | 1997-07 |
| S. Josefsson | jas&extundo.com
http://josefsson.org/shishi/shishi.html#Telnet%20encryption%20with%20AES-CCM |
2003-11 |
| Steve McGregory | stevemc&pragmasys.com | 1998-12 |
| Steven Schoch | schoch&sheba.arc.nasa.gov | 1995-01 |
| Thomas Wu | tjw&stanford.edu | 1998-09 |
| Wirt Atmar | atmar&aics-research.com | 1998-06 |
Footnote
| [1] | Authentication types never submitted to the IETF for consideration as an Internet standard. |