Secret Key Transaction Authentication for DNS (TSIG) Algorithm Names

Created

  • 2000-09

Last Updated

  • 2020-12-02

Available Formats


TSIG Algorithm Names

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8945: Secret Key Transaction Authentication for DNS (TSIG)

Note

TSIG Algorithm names are text strings encoded using the syntax of a domain name. There is no structure required other than names for different algorithms must be unique when compared as DNS names, i.e., comparison is case insensitive. New algorithms are assigned using the IETF Review policy defined in RFC 8126.

Available Formats

Algorithm Name Reference
gss-tsig RFC 3645
HMAC-MD5.SIG-ALG.REG.INT RFC 8945
hmac-sha1 RFC 8945
hmac-sha224 RFC 8945
hmac-sha256 RFC 8945
hmac-sha384 RFC 8945
hmac-sha512 RFC 8945
hmac-sha256-128 RFC 4868; RFC 8945
hmac-sha384-192 RFC 4868; RFC 8945
hmac-sha512-256 RFC 4868; RFC 8945