Two-way Active Measurement Protocol (TWAMP) Parameters

Created

  • 2008-08-13

Last Updated

  • 2024-02-01

Available Formats


TWAMP-Control Command Numbers

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5357: A Two-Way Active Measurement Protocol (TWAMP)
  • RFC 5938: Individual Session Control Feature for the Two-Way Active Measurement Protocol (TWAMP)

Available Formats

Value Description Semantics Definition Reference
0 Reserved RFC 5357
1 Forbidden RFC 5357
2 Start-Sessions Section 3.7 RFC 4656
3 Stop-Sessions Section 3.8 RFC 4656
4 Reserved RFC 5357
5 Request-TW-Session Section 3.5 RFC 5357
6 Experimentation undefined, see Section 8.3 RFC 5357
7 Start-N-Sessions Section 3.2 RFC 5938
8 Start-N-Ack Section 3.3 RFC 5938
9 Stop-N-Sessions Section 3.4 RFC 5938
10 Stop-N-Ack Section 3.5 RFC 5938
11 Request-TW-Micro-Sessions Section 4.1 RFC 9533
12-255 Unassigned

TWAMP-Modes

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5618: Mixed Security Mode for the Two-Way Active Measurement Protocol (TWAMP)
  • RFC 5938: Individual Session Control Feature for the Two-Way Active Measurement Protocol (TWAMP)
  • RFC 7717: IKEv2-Derived Shared Secret Key for the One-Way Active Measurement Protocol (OWAMP) and Two-Way Active Measurement Protocol (TWAMP)

Available Formats

Bit Position Description Semantics Definition Reference
0 Unauthenticated Section 3.1 RFC 4656
1 Authenticated Section 3.1 RFC 4656
2 Encrypted Section 3.1 RFC 4656
3 Unauth. TEST protocol, Encrypted CONTROL Section 3.1 RFC 5618
4 Individual Session Control RFC 5938
5 Reflect Octets Capability RFC 6038
6 Symmetrical Size Sender Test Packet Format RFC 6038
7 IKEv2Derived Mode Capability Section 5 RFC 7717
8 DSCP and ECN Monitoring Capability Section 2 RFC 7750
9 PTPv2 Timestamp Capability Section 2 RFC 8186
10-31 Unassigned