User Datagram Protocol (UDP)

Created

  • 2025-03-25

Last Updated

  • 2025-10-08

Available Formats


UDP Option Kind Numbers

Registration Procedure(s)

  • Standards Action or IESG Approval

Reference

Note

Codepoints 0-7 MUST be supported on any implementation supporting UDP Options. All others are supported at the discretion of each implementation.

Available Formats

Kind Length Meaning Reference
0 - End of Options List (EOL) RFC 9868
1 - No Operation (NOP) RFC 9868
2 6 Additional Payload Checksum (APC) RFC 9868
3 10/12 Fragmentation (FRAG) RFC 9868
4 4 Maximum Datagram Size (MDS) RFC 9868
5 5 Maximum Reassembled Datagram Size (MRDS) RFC 9868
6 6 Request (REQ) RFC 9868
7 6 Response (RES) RFC 9868
8 10 Timestamp (TIME) RFC 9868
9 (varies) RESERVED for Authentication (AUTH) RFC 9868; draft-touch-tsvwg-udp-auth-opt-00
10-126 (varies) Unassigned
127 (varies) RFC 3692-style experiments (EXP) RFC 9868
128-191 Reserved RFC 9868
192 (varies) Reserved for UNSAFE Compression (UCMP) RFC 9868
193 (varies) Reserved for UNSAFE Encryption (UENC) RFC 9868
194-253 Unassigned - UNSAFE
254 (varies) RFC 3692-style UNSAFE experiments (UEXP) RFC 9868
255 Reserved - UNSAFE RFC 9868

TCP/UDP Experimental Option Experiment Identifiers (TCP/UDP ExIDs)

Reference

  • RFC 6994: Shared Use of Experimental TCP Options
  • RFC 9868: Transport Options for UDP

Note

See TCP/UDP Experimental Option Experiment Identifiers (TCP/UDP ExIDs).