Unidirectional Lightweight Encapsulation (ULE) Next-Header Registry

Created

  • 2005-09-13

Last Updated

  • 2014-08-07

Note

The Mandatory Extension Header range in the ULE Next-Header registry is used to allocate integer values in the range 0-255 (decimal). These values are used to identify mandatory extension headers. The registered value corresponds to the 16-bit Type value for the mandatory extension header or the specified protocol.

The Optional Extension Header range in the ULE Next-Header registry is used to allocate integer values in the range 256-511 (decimal). These values are used to identify optional extension headers. The registered value corresponds to the 16-bit Type value that would be used for an optional extension header with a header length (H-LEN) of 1.

Note

The range 512-1535 is also assigned for Optional Extension Headers. IANA does not allocate numbers in this range. The values are derived from the combination of a registry entry in the range 256-511, and the corresponding H-LEN values specified in each registry entry RFC 4326.

Available Formats


Mandatory Extension Headers (or link-dependent type fields) for ULE (Range 0-255 decimal)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Gorry Fairhurst

Reference

  • RFC 4326: Unidirectional Lightweight Encapsulation (ULE) for Transmission of IP Datagrams over an MPEG-2 Transport Stream (TS)
  • RFC 7280: IANA Guidance for Managing the Unidirectional Lightweight Encapsulation (ULE) Next-Header Registry

Available Formats

Type Name Reference
0 Test-SNDU RFC 4326
1 Bridged-SNDU RFC 4326
2 TS-Concat RFC 5163
3 PDU-Concat RFC 5163
4-128 Unassigned
129 LL_GSE_NCR EN 301 545-2; Hans-Peter Lexow
130 LL_RCS_L2S EN 301 545-2; Hans-Peter Lexow
131 LL_RCS_DCP TS 101 545-3; Hans-Peter Lexow
132 LL_RCS_1 EN 301 545-2; Gorry Fairhurst
133 LL_RCS_TRANSEC_SYS EN 301 545-1; Gorry Fairhurst
134 LL_RCS_TRANSEC_PAY EN 301 545-1; Gorry Fairhurst
135 DVB-GSE_LLC ETSI TS 102 606-2; Alexander Adolf
136-143 Unassigned
144-159 Reserved for Private Use RFC 7280
160-199 Unassigned
200 LL_RCS_FEC_FDT EN 301 790 V1.5.1; Laurence Duquerroy
201-255 Unassigned

Optional Extension Headers for ULE (Range 256-511 decimal)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Gorry Fairhurst

Reference

  • RFC 4326: Unidirectional Lightweight Encapsulation (ULE) for Transmission of IP Datagrams over an MPEG-2 Transport Stream (TS)
  • RFC 7280: IANA Guidance for Managing the Unidirectional Lightweight Encapsulation (ULE) Next-Header Registry

Available Formats

Type Name H-LEN Reference
256 Extension-Padding 1-5 RFC 4326
257 Time-Stamp 3 RFC 5163
258-449 Unassigned
450 LL_RCS_FEC_ADT 4 EN 301 790 V1.5.1; Laurence Duquerroy
451 LL_CRC32 3 EN 301 790 V1.5.1; Laurence Duquerroy
452-511 Unassigned

Contact Information

Name Contact URI Last Updated
Alexander Adolf alexander.adolf&condition-alpha.com 2013-12-18
Gorry Fairhurst gorry&erg.abdn.ac.uk 2013-02-06
Hans-Peter Lexow hlexow&stmi.com 2013-02-06
Laurence Duquerroy Laurence.Duquerroy&esa.int 2008-08-28