UUID Subtypes
Registration Procedure(s)
- Standards Action With Expert Review
Expert(s)
- Kyzer Davis, Brad Peabody
Reference
- RFC 9562: Universally Unique IDentifiers (UUIDs)
Available Formats
| ID | Name | Subtype | Variant | Reference |
|---|---|---|---|---|
| 1 | Gregorian Time-based | version | OSF DCE / IETF | RFC 4122; RFC 9562 |
| 2 | DCE Security | version | OSF DCE / IETF | C309; C311 |
| 3 | MD5 Name-based | version | OSF DCE / IETF | RFC 4122; RFC 9562 |
| 4 | Random | version | OSF DCE / IETF | RFC 4122; RFC 9562 |
| 5 | SHA-1 Name-based | version | OSF DCE / IETF | RFC 4122; RFC 9562 |
| 6 | Reordered Gregorian Time-based | version | OSF DCE / IETF | RFC 9562 |
| 7 | Unix Time-based | version | OSF DCE / IETF | RFC 9562 |
| 8 | Custom | version | OSF DCE / IETF | RFC 9562 |
UUID Namespace IDs
Registration Procedure(s)
- Specification Required
Expert(s)
- Kyzer Davis, Brad Peabody
Reference
- RFC 9562: Universally Unique IDentifiers (UUIDs)
Available Formats
| Namespace | Namespace ID Value | Name Reference | Namespace ID Reference |
|---|---|---|---|
| DNS | 6ba7b810-9dad-11d1-80b4-00c04fd430c8 | RFC 9499 | RFC 4122; RFC 9562 |
| URL | 6ba7b811-9dad-11d1-80b4-00c04fd430c8 | RFC 1738 | RFC 4122; RFC 9562 |
| OID | 6ba7b812-9dad-11d1-80b4-00c04fd430c8 | ISO/IEC 9834-1, ITU-T Rec. X.660, 2011 | RFC 4122; RFC 9562 |
| X500 | 6ba7b814-9dad-11d1-80b4-00c04fd430c8 | ISO/IEC 9594-1, ITU-T Rec. X.500, 2019 | RFC 4122; RFC 9562 |
| CBOR PEN | 47fbdabb-f2e4-55f0-bb39-3620c2f6df4e | RFC-ietf-suit-manifest-34 | RFC-ietf-suit-manifest-34 |