| MBWS.huawei.com |
MBWS |
draft-hapner-hybi-messagebroker-subprotocol-01 (Page 9) |
Mark Hapner |
|
| MBLWS.huawei.com |
MBLWS |
draft-hapner-hybi-messagebroker-subprotocol-01 (Page 9) |
Mark Hapner |
|
| soap |
soap |
http://go.microsoft.com/fwlink/?LinkID=231897&clcid=0x409 |
Paul Batum |
|
| wamp |
WAMP ("The WebSocket Application Messaging Protocol") |
https://wamp-proto.org/spec.html |
WAMP |
Tobias Oberstein |
| v10.stomp |
Name: STOMP 1.0 specification |
https://stomp.github.io/stomp-specification-1.0.html |
Jeff Mesnil |
|
| v11.stomp |
Name: STOMP 1.1 specification |
https://stomp.github.io/stomp-specification-1.1.html |
Jeff Mesnil |
|
| v12.stomp |
Name: STOMP 1.2 specification |
https://stomp.github.io/stomp-specification-1.2.html |
Jeff Mesnil |
|
| ocpp1.2 |
OCPP 1.2 |
http://www.gir.fr/ocppjs/ocpp_srpc_spec.shtml |
Open Charge Alliance |
|
| ocpp1.5 |
OCPP 1.5 |
https://www.openchargealliance.org/downloads/ |
Open Charge Alliance |
|
| ocpp1.6 |
OCPP 1.6 |
https://www.openchargealliance.org/downloads/ |
Open Charge Alliance |
|
| ocpp2.0 |
OCPP 2.0 |
https://www.openchargealliance.org/downloads/ |
Open Charge Alliance |
|
| ocpp2.0.1 |
OCPP 2.0.1 |
https://www.openchargealliance.org/downloads/ |
Open Charge Alliance |
|
| ocpp2.1 |
OCPP 2.1 |
https://www.openchargealliance.org/downloads/ |
Open Charge Alliance |
Open Charge Alliance |
| rfb |
RFB |
RFC 6143 |
Tristan Richardson |
|
| sip |
WebSocket Transport for SIP (Session Intiation Protocol) |
RFC 7118 |
RFC 7118 |
|
| notificationchannel-netapi-rest.openmobilealliance.org |
OMA RESTful Network API for Notification Channel |
OMA RESTful Network API for Notification Channel V 1.0, Open Mobile Alliance, OMA-TS-REST_NetAPI_NotificationChannel-V1_0 |
OMNA - Open Mobile Naming Authority; Uwe Rauschenbach |
|
| wpcp |
Web Process Control Protocol (WPCP) |
http://wpcp.net/spec/ |
Patrick Gansterer |
|
| amqp |
Advanced Message Queuing Protocol (AMQP) 1.0+ |
http://docs.oasis-open.org/amqp-bindmap/amqp-wsb/v1.0/csprd02/amqp-wsb-v1.0-csprd02.pdf |
Robin Cover |
|
| mqtt |
mqtt |
MQTT Version 5.0 |
Chet Ensign |
|
| jsflow |
jsFlow pubsub/queue protocol |
http://www.jsflow.com/definition |
Magnus Lundstedt |
|
| rwpcp |
Reverse Web Process Control Protocol (RWPCP) |
http://wpcp.net/spec/ |
Patrick Gansterer |
|
| xmpp |
WebSocket Transport for the Extensible Messaging and Presence Protocol (XMPP) |
RFC 7395 |
RFC 7395 |
|
| ship |
SHIP - Smart Home IP |
SHIP (Smart Home IP) is a an IP based approach to plug and
play home automation and smart energy / energy efficiency, which can
easily be extended to additional domains such as Ambient Assisted
Living (AAL). SHIP can be used solely on the customer premises or can
be integrated into a cloud based solution. |
EEBus Initiative; Andreas Westermann |
|
| mielecloudconnect |
Miele Cloud Connect Protocol |
This protocol is used to securely connect household or
professional appliances to an internet service portal via a public
communication network in order to enable remote services. The
specification is not published yet. |
Nils Langhammer |
|
| v10.pcp.sap.com |
Push Channel Protocol |
https://scn.sap.com/community/abap/connectivity/blog/2015/07/27/specification-of-the-push-channel-protocol-pcp |
Masoud Aghadavoodi Jolfaei |
|
| msrp |
WebSocket Transport for MSRP (Message Session Relay Protocol) |
RFC 7977 |
RFC 7977; RFC 8873 |
|
| v1.saltyrtc.org |
SaltyRTC 1.0 |
https://github.com/saltyrtc/saltyrtc-meta/blob/master/Protocol.md |
Lennart Grahl |
|
| TLCP-2.0.0.lightstreamer.com |
TLCP (Text Lightstreamer Client Protocol) |
http://www.lightstreamer.com/tlcp-2.0.0 |
Alessandro Alinone |
Lightstreamer Srl |
| bfcp |
WebSocket Transport for BFCP (Binary Floor Control Protocol) |
RFC 8857 |
RFC 8857 |
|
| sldp.softvelum.com |
Softvelum Low Delay Protocol |
SLDP is a low latency live streaming protocol for delivering media from
servers to MSE-based browsers and WebSocket-enabled applications. |
Yuri Udovichenko |
|
| opcua+uacp |
OPC UA Connection Protocol |
https://opcfoundation.org/developer-tools/specifications-unified-architecture/part-6-mappings/ |
OPC Foundation |
|
| opcua+uajson |
OPC UA JSON Encoding |
https://opcfoundation.org/developer-tools/specifications-unified-architecture/part-6-mappings/ |
OPC Foundation |
|
| v1.swindon-lattice+json |
Swindon Web Server Protocol (JSON encoding) |
https://swindon-rs.github.io/swindon/swindon-lattice/ |
Paul Colomiets |
|
| v1.usp |
USP (Broadband Forum User Services Platform) |
https://usp.technology/specification/mtp/websocket |
Broadband Forum |
|
| mles-websocket |
mles-websocket |
https://github.com/jq-rs/mles-rs/blob/master/README.md |
Juhamatti Kuusisaari |
|
| coap |
Constrained Application Protocol (CoAP) |
RFC 8323 |
RFC 8323 |
|
| TLCP-2.1.0.lightstreamer.com |
TLCP (Text Lightstreamer Client Protocol) |
http://www.lightstreamer.com/tlcp-2.1.0 |
Dario Crivelli |
Lightstreamer Srl |
| sqlnet.oracle.com |
sqlnet |
This protocol is used for communication between Oracle
database client and database server, and its usage as subprotocol
of websocket is primarly geared towards cloud deployments. sqlnet
supports bi-directional data transfer and is full duplex in nature. |
Feroz Alam Khan |
|
| oneM2M.R2.0.json |
oneM2M R2.0 JSON |
http://ftp.onem2m.org/Work%20Programme/WI-0040/TS-0020-WebSocket_Protocol_Binding-V2_2_0.ZIP |
Miguel Angel Reina Ortega |
|
| oneM2M.R2.0.xml |
oneM2M R2.0 XML |
http://ftp.onem2m.org/Work%20Programme/WI-0040/TS-0020-WebSocket_Protocol_Binding-V2_2_0.ZIP |
Miguel Angel Reina Ortega |
|
| oneM2M.R2.0.cbor |
oneM2M R2.0 CBOR |
http://ftp.onem2m.org/Work%20Programme/WI-0040/TS-0020-WebSocket_Protocol_Binding-V2_2_0.ZIP |
Miguel Angel Reina Ortega |
|
| transit |
Transit |
https://github.com/Randy-Buchholz/Transit |
Randy Buchholz |
|
| 2016.serverpush.dash.mpeg.org |
MPEG-DASH-ServerPush-23009-6-2017 |
https://www.iso.org/standard/71072.html |
Imed_Bouazizi |
|
| 2018.mmt.mpeg.org |
MPEG-MMT-23008-1-2018 |
https://www.iso.org/standard/76386.html |
Imed_Bouazizi |
|
| clue |
clue |
RFC 8850 |
RFC 8850 |
|
| webrtc.softvelum.com |
Softvelum WebSocket signaling protocol |
WebRTC live streaming requires WebSocket-based signaling protocol for
every specific implementation. Softvelum products will use this subprotocol for
signaling. |
Yuri Udovichenko |
|
| cobra.v2.json |
Cobra Real Time Messaging Protocol |
https://machinezone.github.io/cobra/api/ |
Benjamin Sergeant |
|
| drp |
Declarative Resource Protocol |
https://github.com/adhdtech/DRP |
Pete Brown |
|
| hub.bsc.bacnet.org |
BACnet Secure Connect Hub Connection |
Addendum BJ to ANSI/ASHRAE Standard 135-2016 |
Bernhard Isler |
ASHRAE Inc. |
| dc.bsc.bacnet.org |
BACnet Secure Connect Direct Connection |
Addendum BJ to ANSI/ASHRAE Standard 135-2016 |
Bernhard Isler |
ASHRAE Inc. |
| jmap |
WebSocket Transport for JMAP (JSON Meta Application Protocol) |
RFC 8887 |
RFC 8887 |
|
| t140 |
ITU-T T.140 Real-Time Text |
RFC 8865 |
RFC 8865 |
|
| done |
done.best IoT Protocol |
"done" is a general purpose IoT Protocol, used by done.best based solutions |
done.best |
Helmut Hartl |
| TLCP-2.2.0.lightstreamer.com |
TLCP (Text Lightstreamer Client Protocol) |
https://www.lightstreamer.com/tlcp-2.2.0 |
Dario Crivelli |
Lightstreamer Srl |
| collection-update |
The Collection Update Websocket Subprotocol |
https://github.com/jonlachlan/collection-update-websocket-protocol |
Jon Lachlan |
Jon Lachlan |
| TLCP-2.3.0.lightstreamer.com |
TLCP (Text Lightstreamer Client Protocol) |
https://lightstreamer.com/tlcp-2.3.0 |
Dario Crivelli |
Lightstreamer Srl |
| text.ircv3.net |
Text IRC Protocol |
https://ircv3.net/specs/extensions/websocket |
Daniel Oakley |
IRCv3 Working Group |
| binary.ircv3.net |
Binary IRC Protocol |
https://ircv3.net/specs/extensions/websocket |
Daniel Oakley |
IRCv3 Working Group |
| v3.penguin-stats.live+proto |
Penguin statistics Live Protocol v3 (Protobuf encoding) |
https://github.com/penguin-statistics/backend-next/blob/main/internal/models/protos/messages.proto |
Galvin Gao; Alviss Reimu |
Galvin Gao; Alviss Reimu |
| TLCP-2.4.0.lightstreamer.com |
TLCP (Text Lightstreamer Client Protocol) |
https://www.lightstreamer.com/tlcp-2.4.0 |
Dario Crivelli |
Lightstreamer Srl |
| TLCP-2.5.0.lightstreamer.com |
TLCP (Text Lightstreamer Client Protocol) |
https://www.lightstreamer.com/tlcp-2.5.0 |
Dario Crivelli |
Lightstreamer Srl |
| Redfish |
Redfish Specification DSP0266 |
https://www.dmtf.org/dsp/DSP0266 |
DMTF Administration |
DMTF Administration |
| bidib |
webBiDiB |
https://bidib.org/transport/bidib_net_e.html |
BiDiB & Tools e.V. |
BiDiB & Tools e.V. |
| json.webpubsub.azure.v1 |
Azure Web PubSub subprotocol JSON |
https://learn.microsoft.com/azure/azure-web-pubsub/reference-json-webpubsub-subprotocol |
Kevin Guo |
Kevin Guo |
| protobuf.webpubsub.azure.v1 |
Azure Web PubSub subprotocol protobuf |
https://learn.microsoft.com/azure/azure-web-pubsub/reference-protobuf-webpubsub-subprotocol |
Kevin Guo |
Kevin Guo |
| json.reliable.webpubsub.azure.v1 |
Azure Web PubSub subprotocol reliable JSON |
https://learn.microsoft.com/en-us/azure/azure-web-pubsub/reference-json-reliable-webpubsub-subprotocol |
Kevin Guo |
Kevin Guo |
| protobuf.reliable.webpubsub.azure.v1 |
Azure Web PubSub subprotocol reliable protobuf |
https://learn.microsoft.com/azure/azure-web-pubsub/reference-protobuf-reliable-webpubsub-subprotocol |
Kevin Guo |
Kevin Guo |
| WebREPL.binary.v1 |
WebREPL Binary Protocol |
https://jetpax.github.io/webrepl/webrepl_binary_protocol_rfc.md |
Jonathan E. Peace |
Jonathan E. Peace |
| camp |
Cryo Application Messaging Protocol |
https://github.com/Ranchonyx/CAMP-Protocol/releases/tag/v1.0.0 |
Felix Janetzki |
Felix Janetzki |
| port42 |
The Port42 Protocol |
https://port42.ai/protocol/websocket.html |
Gordon Mattey |
Gordon Mattey |