YANG SIDs

Created

  • 2024-01-26

Last Updated

  • 2026-07-24

Available Formats


YANG-SID Mega-Ranges

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Michel Veillette, Alexander Pelov, Laurent Toutain

Reference

  • RFC 9595: YANG Schema Item iDentifier (YANG SID)

Available Formats

Entry Point Size Allocation Organization Name URL Reference
0 1000000 Public IANA https://www.iana.org RFC 9595
3000000000 1000000000 Private IANA RFC 9997 RFC 9997
3324730000 10000 Reserved for Documentation RFC 9997
300000000000 100000000000 Private IANA RFC 9997 RFC 9997
303247300000 100000 Reserved for Documentation RFC 9997

IETF YANG-SID Ranges

Expert(s)

  • Michel Veillette, Alexander Pelov, Laurent Toutain

Reference

  • RFC 9595: YANG Schema Item iDentifier (YANG SID)

Available Formats

Entry Point Size Registration Procedures Note
0 1000 IESG Approval
1000 59000 RFC Required (or Expert Review if YANG comes from existing RFC) See RFC 9595, Section 6.4.2, Item 2
60000 40000 Reserved for Experimental Use
100000 200000 RFC Required (or Expert Review if YANG comes from existing RFC) See RFC 9595, Section 6.4.2, Item 2
300000 700000 Reserved
Entry Point Size Module Name Reference
0 1 (Reserved: not a valid SID) RFC 9595
1000 100 ietf-coreconf RFC 9595; draft-ietf-core-comi-16
1100 50 ietf-yang-types RFC 9911
1150 50 ietf-inet-types RFC 9911
1200 50 iana-crypt-hash RFC 7317
1250 50 ietf-netconf-acm RFC 8341
1300 50 ietf-sid-file RFC 9595
1500 100 ietf-interfaces RFC 8343
1600 100 ietf-ip RFC 8344
1700 100 ietf-system RFC 7317
1800 400 iana-if-type RFC 7224
2450 50 ietf-voucher (TEMPORARY - registered 2024-07-15, publication requested 2026-01-31) draft-ietf-anima-rfc8366bis-12
2500 50 ietf-voucher-request (TEMPORARY - registered 2024-07-15, publication requested 2026-01-31) draft-ietf-anima-rfc8366bis-12
2550 400 ietf-schc RFC 9363

IETF YANG-SID Modules

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Michel Veillette, Alexander Pelov, Laurent Toutain

Reference

  • RFC 9595: YANG Schema Item iDentifier (YANG SID)
YANG Module Name YANG File SID File Size Reference
No registrations at this time.